又到了一年一度機器被掃的時刻了,這次碰到的問題是 OpenSSL 版本太舊,有資安疑慮。

然而在 Ubuntu 上安裝時,直接用 ./config 後,安裝完的路徑卻不太對。網路上有看到別人用 ln -s 的方式強制切換位置,但安裝其他軟體時,一樣容易碰到 openssl header 跟 openssl library 版本不合的問題,摸索一下才找到正確的解法。

$ sudo apt-get remove openssl libssl-dev

$ tar -xvf openssl-w.x.yz.tar.gz
$ cd openssl-w.x.yz
$ ./config --prefix=/usr
$ sudo make install

如此一來才安全地搞定了。確認 OpenSSL 版本:

$ openssl version -a

只是更新完還有一堆東西要重編 Orz


, , , ,

changyy 發表在 痞客邦 PIXNET 留言(0) 人氣()